Site slowness
Incident Report for PeopleGrove
Resolved
We are continuing to monitor the slowness, but response times have returned to normal.
Posted Sep 13, 2023 - 15:25 UTC
Update
We are continuing to investigate this issue.
Posted Sep 13, 2023 - 15:00 UTC
Investigating
We are investigating site slowness that is affecting US clients. We will post an update as soon as possible.
Posted Sep 13, 2023 - 15:00 UTC
This incident affected: PeopleGrove Application.