Partially degraded performance
Incident Report for PeopleGrove
Resolved
We have been monitoring the issue and performance has been normal and the platform is functioning normally.
Posted Mar 23, 2022 - 21:56 UTC
Monitoring
We have identified the reason for the site slowness, and have implemented a fix. Sites should be functioning normally now. We are continuing to monitor the performance.
Posted Mar 23, 2022 - 19:28 UTC
Investigating
We are investigating an issue causing slowness on the PeopleGrove platform. We will provide an update as soon as possible.
Posted Mar 23, 2022 - 18:24 UTC
This incident affected: PeopleGrove Application.