Degraded site performance
Incident Report for PeopleGrove
Resolved
The incident has been resolved.
Posted Oct 24, 2022 - 19:28 UTC
Monitoring
We have identified the cause of the issues, and implemented a fix. Site load times have returned to normal. We are continuing to monitor the issue.
Posted Oct 24, 2022 - 18:45 UTC
Update
We are continuing to investigate this issue.
Posted Oct 24, 2022 - 18:22 UTC
Investigating
We are currently investigating degraded site performance. PeopleGrove platforms may be slow to access. We are investigating and will provide an update shortly.
Posted Oct 24, 2022 - 18:22 UTC
This incident affected: PeopleGrove Application.